Note: Advice in this article will only work for DotNetBrowser 1.
See the corresponding article for DotNetBrowser 2 here.

Since DotNetBrowser 1.7 Java Applet plugin isn't supported, because it's NPAPI plugin which isn't supported by Chromium engine at all. Chromium supports only PPAPI plugins.